Please ensure Javascript is enabled for purposes of website accessibility
PRC-Saltillo Logo
PRC Logo
Saltillo Logo
Realize Language Logo
ExploreAAC Logo
AAC Language Lab Logo
AAC And Autism Logo
ALP for AAC Logo
Touch Chat App Logo
LAMP Words for Life Logo
Dialogue AAC App
AAC Funding
AAC Learning Journey
AAC Group Coaching
PRC-Saltillo Store
Minspeak Academy
https://auth.prc-saltillo.com/v1/authorize?response_type=code&redirect_uri=https%3A%2F%2Fprc-saltillo.com%2Flogin&client_id=prcsaltillo&nonce=8af3c66714ec63bceea693589880d8bc&state=e344c5e87a914ad1352b7b7fa0a3558b&scope=admin.read+address.write+area.read+email.read+openid.read+phone.write+profile.write+service.write+software.read+terms.write+title.write+user.write+verification.write Create New Account

An issue has been identified that is preventing Empower software from loading on Accent devices. Read more for detailed instructions for how to fix your device. We sincerely apologize for any inconvenience this may have caused.

We only use strictly necessary cookies for this website. Please see the privacy policy for more information.   


Dialogue AAC Update 2.33.0 is here…read below for important information.

Starting with this 2.33.0 release, support is discontinued for iOS 11.

  • Why?
    • Dialogue AAC screenshotWith every release, we ensure that new features can be used by supported iOS versions (recently iOS 11-15.0.1). As technology advances rapidly, it is increasingly difficult to ensure compatibility with out-of-date iOS versions. In order to provide our iOS customers with the best Dialogue AAC app experience, we have decided to discontinue support for iOS 11.
  • Anything you need to do?
    • We advise our iOS users running iOS 11 to upgrade to a higher iOS version, ideally the latest version. By doing this, you'll gain access to all the latest updates and features - giving you the best Dialogue AAC app experience!
  • What are the new minimum supported iOS devices?
    • The minimum requirement for iOS devices supported by the Dialogue AAC app is iOS version 12.0 or later.
  • What if your device doesn't support iOS 12?
    • If your device doesn't support any of the newer iOS versions, you should know that:
      • You can still use Dialogue AAC app version 2.32.1 and will be able to continue to use that even after October 2021; however:
      • You will not be able to update beyond 2.32.1. Therefore, new features introduced in 2.33.0 and beyond will not be available on devices running iOS 11.

Questions? Please feel free to reach out to us at info@dialogueAACapp.com.



Software Updates  -    dialogue aac, aac, aac app, dialogue aac update, ios dialogue aac, prc app, prc-saltillo app, saltillo app